War2.ru Slogan
News: Back by popular demand, the SMF Arcade!!!
PLAY NOW!!!!!!!!!!!!!!!!!!!!!!!!


Welcome, Guest. Please login or register.

Login with username, password and session length
Welcome to the forums! We're glad to have you here! :) You can register your account here, then feel free to introduce yourself in the Server.War2.ru board & let us know who you are on the server.

W2 in 4:3 ratio 1010  8

Peon Posts: 36 Karma: +2/-0 **

BHC-JesK

  • Peon
  • **
  • *
  • Posts: 36
    • View Profile
W2 in 4:3 ratio
« on: September 28, 2020, 02:18:23 PM »
Hello,

since my switch to new hardware and win10 my w2 keeps stretching to 16:9 and i want to play in 4:3. The setting in the war2 config didn't help.

I use combat 4.6 and the most recent amd radeon drivers. The keep ratio setting in the radeon driver didn't help either.

Anyone got it running with amd drivers?

cheers
Ogre Mage Posts: 1989 Karma: +174/-18 ********

TNARICK

  • Ogre Mage
  • ********
  • *
  • Posts: 1989
    • View Profile
    • Warcraft 2 Server
Re: W2 in 4:3 ratio
« Reply #1 on: September 28, 2020, 02:37:31 PM »
Have you tried opening the NVIDIA Control Panel?
Death Knight Posts: 4031 Karma: +159/-101 *********

Nox

  • Death Knight
  • *********
  • *
  • Posts: 4031
    • View Profile
*

Nox

Re: W2 in 4:3 ratio
« Reply #2 on: September 28, 2020, 04:40:06 PM »
Hello,

since my switch to new hardware and win10 my w2 keeps stretching to 16:9 and i want to play in 4:3. The setting in the war2 config didn't help.

I use combat 4.6 and the most recent amd radeon drivers. The keep ratio setting in the radeon driver didn't help either.

Anyone got it running with amd drivers?

cheers

What is ur new hardware? Monitor? Look in the monitor setting, most of time you can ajust 4:3 from ur monitor.
Server Admin Berserker Posts: 591 Karma: +59/-4 *****

woofy

  • Server Admin
  • Berserker
  • *****
  • Posts: 591
    • View Profile
Re: W2 in 4:3 ratio
« Reply #3 on: September 28, 2020, 08:23:32 PM »
Yeah it's monitor dependent. My last monitor setup I had for several years wouldn't auto-switch to the correct aspect ratio, so I had to manually change to 4:3 whenever I wanted to play. My new setup auto adjusts, so pretty happy about that!
Axe Thrower Posts: 439 Karma: +26/-3 ****

(PLS DELETE MY ACC)

  • Axe Thrower
  • ****
  • Posts: 439
    • View Profile
Re: W2 in 4:3 ratio
« Reply #4 on: September 29, 2020, 07:51:12 AM »
NO IDEA ABOUT UR DRIVERS BUT ID LOOK FOR "KEEP/PRESERVE ASPECT RATIO"

SO SOMETHIN LIKE DIS (A RANDOM RESULT FROM GUUGLE):
https://www.amd.com/en/support/kb/faq/gpu-68#faq-Accessing-Scaling-Mode-in-AMD-Radeon-Software
Grunt Posts: 134 Karma: +4/-1 ***

maciek

  • Grunt
  • ***
  • *
  • Posts: 134
    • View Profile
Re: W2 in 4:3 ratio
« Reply #5 on: September 29, 2020, 07:59:40 AM »
change screen resolution to 4:3, start war2, change resolution back to 16:9
Grunt Posts: 77 Karma: +3/-1 ***

Droid

  • Grunt
  • ***
  • *
  • Posts: 77
    • View Profile
Re: W2 in 4:3 ratio
« Reply #6 on: September 29, 2020, 01:47:32 PM »
Well I haven't realized it was 16:9 and got used to it. Now I like it and 3:4 seems kinda strange to me.

But that's the way we live in Russia, getting used to some shit...
Polish hackers gave you good solutions. Maybe one day I will fix it too.
Peon Posts: 36 Karma: +2/-0 **

BHC-JesK

  • Peon
  • **
  • *
  • Posts: 36
    • View Profile
Re: W2 in 4:3 ratio
« Reply #7 on: September 30, 2020, 01:13:11 PM »
Yeah it's monitor dependent. My last monitor setup I had for several years wouldn't auto-switch to the correct aspect ratio, so I had to manually change to 4:3 whenever I wanted to play. My new setup auto adjusts, so pretty happy about that!

I think it's a combination of the monitor and display driver since i didn't change my monitor. With my old win7 PC it just worked, then after a display driver update i had to fiddle around with some 3rd party fix to get it working again. The old fix didn't work now.
At the moment i have to set the monitor manually to 4:3 which is pretty annoying obviously.

NO IDEA ABOUT UR DRIVERS BUT ID LOOK FOR "KEEP/PRESERVE ASPECT RATIO"

SO SOMETHIN LIKE DIS (A RANDOM RESULT FROM GUUGLE):
https://www.amd.com/en/support/kb/faq/gpu-68#faq-Accessing-Scaling-Mode-in-AMD-Radeon-Software

That's what i checked first, doesn't work unfortunately.
Sappers Posts: 763 Karma: +33/-3 ******

{Lance}

  • Sappers
  • ******
  • Posts: 763
    • View Profile
Re: W2 in 4:3 ratio
« Reply #8 on: October 06, 2020, 04:01:57 PM »
If you have an nvidia card,  it's a setting in the Nvidia control panel called "No Scaling".  In the "Display" section you'll see one of 3 options selected (probably either Full screen or Aspect ratio).  Select "No scaling" and it wont stretch war2 anymore.